An Interface and Algorithms for Authenticated Encryption
Abstract
This document defines algorithms for Authenticated Encryption with Associated Data (AEAD), and defines a uniform interface and a registry for such algorithms. The interface and registry can be used as an application-independent set of cryptoalgorithm suites. This approach provides advantages in efficiency and security, and promotes the reuse of crypto implementations. [STANDARDS-TRACK]
Integrity signals
Registry
Cites
Statistics
Claims the paper makes
Cited by
Sorted by citations
The Software Performance of Authenticated-Encryption Modes
Krovetz, T., & Rogaway, P. (2011) · Lecture notes in computer science · doi:10.1007/978-3-642-21702-9_18 · Cited by 266 · see citing works
ChaCha20 and Poly1305 for IETF Protocols
Nir, Y., & Langley, A. (2015) · doi:10.17487/rfc7539 · Cited by 141 · see citing works
AES Galois Counter Mode (GCM) Cipher Suites for TLS
Salowey, J., Choudhury, A., & McGrew, D. A. (2008) · doi:10.17487/rfc5288 · Cited by 108 · see citing works
Self-citationAutomated Analysis and Verification of TLS 1.3: 0-RTT, Resumption and Delayed Authentication
Cremers, C. J. F., Horvat, M., Scott, S., et al. (2016) · Proceedings - IEEE Symposium on Security and Privacy/Proceedings of the ... IEEE Symposium on Security and Privacy · doi:10.1109/sp.2016.35 · Cited by 106 · see citing works
“[41]).”
Breaking and Repairing GCM Security Proofs
Iwata, T., Ohashi, K., & Minematsu, K. (2012) · Lecture notes in computer science · doi:10.1007/978-3-642-32009-5_3 · Cited by 94 · see citing works
“Indeed, in many RFCs, such as RFC 4106 (IPsec) [34], 5647 (SSH) [20], 5288 (SSL) [33], the nonce length is fixed to 96 bits, and RFC 5084 [19] and 5116 [25] recommend 96-bit nonces.”
BackgroundMethodImplementing and Proving the TLS 1.3 Record Layer
Delignat-Lavaud, A., Cédric Fournet, A., Kohlweiss, M., et al. (2017) · Proceedings - IEEE Symposium on Security and Privacy/Proceedings of the ... IEEE Symposium on Security and Privacy · doi:10.1109/sp.2017.58 · Cited by 88 · see citing works
“2) We describe a generic AEAD construction that captures both RFC 5288 [41] for AES-GCM (as described in NIST SP800-38D [21]) and RFC 7539 [38] for ChaCha20-Poly1305 through an interface compatible with RFC 5116 [36].”
Sheffer, Y., Holz, R., & Saint-Andre, P. (2015) · doi:10.17487/rfc7525 · Cited by 81 · see citing works
Enhancing LoRaWAN Security through a Lightweight and Authenticated Key Management Approach
Sanchez‐Iborra, R., Sánchez-Gómez, J., Pérez, S., Fernández, P. J., Santa, J., Hernández-Ramos, J. L., & Skármeta, A. (2018) · Sensors · doi:10.3390/s18061833 · Cited by 76 · see citing works
“For the same reason, we selected AES with 128-bit symmetric keys as an Authenticated Encryption with Authenticated Data algorithm (AEAD) [35].”
MethodSecuring IIoT using Defence-in-Depth: Towards an End-to-End secure Industry 4.0
Mosteiro-Sanchez, A., Barcelo, M., Astorga, J., & Urbieta, A. (2020) · Journal of Manufacturing Systems · doi:10.1016/j.jmsy.2020.10.011 · Cited by 64 · see citing works
“Integrity and confidentiality are provided by the Authenticated Encryption with Associated Data algorithm (AEAD) [56], while authentication and authorization come from using the Authentication and Authorisation for Constrained Environments (ACE) standard [77].”
MethodLi, P., Su, J., & Wang, X. (2020) · IEEE Internet of Things Journal · doi:10.1109/jiot.2020.2988126 · Cited by 60 · see citing works
“Both of them can derive the traffic keying material from the shared secret to protect the application-layer data through authenticated encryption with associated data (AEAD) functions [42].”
BackgroundJones, M. B. (2015) · doi:10.17487/rfc7518 · Cited by 55 · see citing works
TLS-N: Non-repudiation over TLS Enabling Ubiquitous Content Signing
Ritzdorf, H., Wüst, K., Gervais, A., Felley, G., & Čapkun, S. (2018) · Network and Distributed System Security Symposium · doi:10.14722/ndss.2018.23272 · Cited by 66 · see citing works
Kounavis, M. E., Kang, X., Grewal, K., et al. (2010) · ACM SIGCOMM Conference (SIGCOMM) · doi:10.1145/1851182.1851200 · Cited by 45 · see citing works
“For the explicit IV we use the recommended method of [33] (3.”
MethodApplication Layer Key Establishment for End-to-End Security in IoT
Pérez, S., Hernández-Ramos, J. L., Raza, S., & Skármeta, A. (2019) · IEEE Internet of Things Journal · doi:10.1109/jiot.2019.2959428 · Cited by 41 · see citing works
“In the case of the AEAD , the AES-CCM algorithm [47], with 128-bit symmetric keys, 64-bit tag, and 7-bit nonce, is selected.”
MethodOn the Effectiveness of End-to-End Security for Internet-Integrated Sensing Applications
Granjal, J., Monteiro, E., & Silva, J. S. (2012) · IEEE International Conference on Green Computing and Communications · doi:10.1109/greencom.2012.23 · Cited by 37 · see citing works
“This mode employs the TLS_PSK_WITH_AES_128_CCM cipher suite in the AEAD (Authenticated Encryption with Associated Data) [13] operational mode AEAD_AES_128_CCM [14], using a 128-bit authentication tags and a 12-byte nonce with each packet protected using the same cryptographic key.”
MethodGGFAST: Automating Generation of Flexible Network Traffic Classifiers
Piet, J., Nwoji, D., & Paxson, V. (2023) · ACM SIGCOMM Conference (SIGCOMM) · doi:10.1145/3603269.3604840 · Cited by 35 · see citing works
Harkins, D. (2008) · doi:10.17487/rfc5297 · Cited by 33 · see citing works
Petullo, W. M., Zhang, X., Solworth, J. A., Bernstein, D. J., & Lange, T. (2013) · ACM SIGSAC Conference on Computer and Communications Security (CCS) · doi:10.1145/2508859.2516737 · Cited by 27 · see citing works
“For example, cryptographers have defined robust high-performance “AEAD” primitives that handle authentication and encryption all at once using a shared secret key [50], taking care of many important details such as padding and key derivation.”
BackgroundNonces Are Noticed: AEAD Revisited
Mihir Bellare, Y., Ng, R., & Tackmann, B. (2019) · Lecture notes in computer science · doi:10.1007/978-3-030-26948-7_9 · Cited by 28 · see citing works
Securing multipath TCP: Design & implementation
Jadin, M., Tihon, G., Pereira, O., et al. (2017) · doi:10.1109/infocom.2017.8057011 · Cited by 25 · see citing works
“1) Protecting data: All data are protected through the use of Authenticated Encryption with Associated Data (AEAD) algorithms: following [22], an encryption algorithm takes data and associated data as inputs (which will be options in our case), and guarantees the integrity of both types of data and the confidentiality…”
MethodTiloca, M., Nikitin, K., & Raza, S. (2017) · ACM Transactions on Embedded Computing Systems · doi:10.1145/3047413 · Cited by 23 · see citing works
“As authenticity is more important than confidentiality in most IoT scenarios, at least ciphersuites with MAC only (NULL encryption) and AEAD [McGrew 2008] ciphersuites must be supported.”
BackgroundInfluentialСовин, Я. Р., Khoma, V., & Podpora, M. (2019) · IEEE Internet of Things Journal · doi:10.1109/jiot.2019.2953230 · Cited by 22 · see citing works
“Moreover, what is very important, it has been standardized in NIST SP 800-38D and RFC5116 [11], [12].”
BackgroundGuidelines for Cryptographic Algorithm Agility and Selecting Mandatory-to-Implement Algorithms
Housley, R. (2015) · Request for Comments · doi:10.17487/rfc7696 · Cited by 21 · see citing works
Securing communication in inter domains Internet of Things using identity-based cryptography
Anggorojati, B., & Prasad, R. (2017) · International Workshop on Big Data and Information Security (IWBIS) · doi:10.1109/iwbis.2017.8275115 · Cited by 20 · see citing works
“Afterwards, the device can request its identifier and corresponding private key securely using Authenticated Encryption with Associated Data (AEAD) [13].”
MethodTLS-N: Non-repudiation over TLS Enabling - Ubiquitous Content Signing for Disintermediation.Preprint
Ritzdorf, H., Wüst, K., Gervais, A., et al. (2017) · IACR Cryptology ePrint Archive · Cited by 19 · see citing works
Network Architecture and Authentication Scheme for LoRa 2.4 GHz Smart Homes
Kane, L., Liu, V., McKague, M., & Walker, G. R. (2022) · IEEE Access · doi:10.1109/access.2022.3203387 · Cited by 18 · see citing works
Pérez, S., García-Carrillo, D., Marín-López, R., et al. (2019) · Future Generation Computer Systems · doi:10.1016/j.future.2019.01.038 · Cited by 17 · see citing works
PROFINET Security: A Look on Selected Concepts for Secure Communication in the Automation Domain
Walz, A., Niemann, K.-H., Göppert, J., et al. (2023) · 2022 IEEE 20th International Conference on Industrial Informatics (INDIN) · doi:10.1109/indin51400.2023.10217985 · Cited by 16 · see citing works
“Symmetric cryptographic protection of data transferred within secure ARs is based on instances from the Authenticated Encryption with Associated Data family of algorithms [19] (e.”
MethodContent Object Security in the Internet of Things: Challenges, Prospects, and Emerging Solutions
Gündoğan, C., Amsüss, C., Schmidt, T. C., & Wählisch, M. (2021) · IEEE Transactions on Network and Service Management · doi:10.1109/tnsm.2021.3099902 · Cited by 16 · see citing works
“We design our experiment to use partially implicit nonces [39].”
MethodBrandt, A., Baccelli, E., Cragie, R., & van der Stok, P. (2016) · doi:10.17487/rfc7733 · Cited by 16 · see citing works
On the feasibility of secure application-layer communications on the Web of Things
Granjal, J., Monteiro, E., & Silva, J. S. (2012) · Conference on Local Computer Networks · doi:10.1109/lcn.2012.6423615 · Cited by 15 · see citing works
“Security modes based on the AEAD_AES_128_CCM_8 AEAD mode require an 8-byte MIC code and a 12-byte nonce.”
MethodAEZ v1.1: Authenticated-Encryption by Enciphering
Hoang, V. T., Krovetz, T., State, S., et al. (2014) · Cited by 15 · see citing works
Berndt, S., Wichelmann, J., Pott, C., et al. (2022) · ACM Asia Conference on Computer and Communications Security (ASIA CCS) · doi:10.1145/3488932.3517387 · Cited by 14 · see citing works
DistriTrust: Distributed and low-latency access validation in zero-trust architecture
Sengupta, B., & Lakshminarayanan, A. (2021) · Journal of Information Security and Applications · doi:10.1016/j.jisa.2021.103023 · Cited by 17 · see citing works
IoT Content Object Security with OSCORE and NDN: A First Experimental ComparisonPreprint
Gündoğan, C., Amsüss, C., Schmidt, T. C., & Wählisch, M. (2020) · arXiv (Cornell University) · doi:10.48550/arxiv.2001.08023 · Cited by 14 · see citing works
“We design our experiment to use partially implicit nonces [28].”
MethodPre-Shared Key Cipher Suites for TLS with SHA-256/384 and AES Galois Counter Mode
Badra, M. (2009) · doi:10.17487/rfc5487 · Cited by 13 · see citing works
Secure Service Proxy: A CoAP(s) Intermediary for a Securer and Smarter Web of Things
den Abeele, F. V., Moerman, I., Demeester, P., et al. (2017) · Sensors · doi:10.3390/s17071609 · Cited by 12 · see citing works
“RFC 5116 [14] introduced Authenticated Encryption with Associated Data (AEAD) to TLS, which enables the use of cipher suites that use the same cipher for confidentiality, authenticity and integrity protection.”
MethodPatton, C., & Shrimpton, T. (2018) · ACM SIGSAC Conference on Computer and Communications Security (CCS) · doi:10.1145/3243734.3243789 · Cited by 12 · see citing works
“3The scheme must specify limits for valid nonce lengths per RFC 5116 [24].”
BackgroundMethodSzymanski, T. H. (2024) · Information · doi:10.3390/info15040173 · Cited by 15 · see citing works
“The IETF standard for AE uses the Chacha20 stream cipher for encryption, with a 512 bit key, and a Poly1305 “Message Authentication Code” (MAC) for authentication [86].”
BackgroundMethodAES-CCM Elliptic Curve Cryptography (ECC) Cipher Suites for TLS
McGrew, D., Bailey, D., Campagna, M., et al. (2014) · doi:10.17487/rfc7251 · Cited by 11 · see citing works
Self-citationIsobe, T., Ito, R., & Minematsu, K. (2021) · Lecture notes in computer science · doi:10.1007/978-3-030-88428-4_7 · Cited by 10 · see citing works
Internet Access for LoRaWAN Devices Considering Security Issues
Sanchez‐Iborra, R., Sánchez-Gómez, J., Pérez, S., et al. (2018) · Global Internet of Things Summit (GIoTS) · doi:10.1109/giots.2018.8534530 · Cited by 10 · see citing works
Bhaumik, R., & Nandi, M. (2017) · Lecture notes in computer science · doi:10.1007/978-3-319-70697-9_22 · Cited by 10 · see citing works
“This is the approach recommended in RFC 5116 [McG08, Sect.”
MethodA path layer for the Internet: Enabling network operations on encrypted protocols
Kühlewind, M., Bühler, T., Trammell, B., et al. (2017) · International Conference on Network and Service Management (CNSM) · doi:10.23919/cnsm.2017.8255973 · Cited by 9 · see citing works
“2) Integrity Protection of the PLUS header: Each QUIC packet header is integrity protected, but not encrypted, using Authenticated Encryption with Additional Data (AEAD) [30].”
MethodKounavis, M. E., Kang, X., Grewal, K., et al. (2010) · ACM SIGCOMM Computer Communication Review · doi:10.1145/1851275.1851200 · Cited by 9 · see citing works
Revised Error Handling for BGP UPDATE Messages
Mohapatra, P., & Patel, K. (2015) · doi:10.17487/rfc7606 · Cited by 9 · see citing works
Reconsidering Generic Composition: The Tag-then-Encrypt Case
Berti, F., Pereira, O., & Peters, T. (2018) · Lecture notes in computer science · doi:10.1007/978-3-030-05378-9_4 · Cited by 8 · see citing works
“Examples of the first path are AES-GCM [12], AESCCM [21], CHACHA20 POLY305 [26] (used in TLS 1.3 [14]), SCT [30] and the CAESAR candidates [8].”
MethodInfluentialNavigating the Quantum Threat Landscape: Addressing Classical Cybersecurity Challenges
Sokol, S. (2023) · Journal of Quantum Information Science · doi:10.4236/jqis.2023.132005 · Cited by 8 · see citing works
Skuballa, M., Walz, A., Bühler, H., et al. (2021) · IEEE International Conference on Emerging Technologies and Factory Automation (ETFA) · doi:10.1109/etfa45728.2021.9613244 · Cited by 7 · see citing works
Covert Channels in Network Time Security
Lamshöft, K., & Dittmann, J. (2022) · ACM Workshop on Information Hiding and Multimedia Security (IH&MMSec) · doi:10.1145/3531536.3532947 · Cited by 7 · see citing works
“(AEAD) [17] to provide cryptographic security for the client-server mode of the Network Time Protocol (NTP).”
BackgroundInfluentialP4EAD: Securing the In-band Control Channels on Commodity Programmable Switches
Bhatnagar, A., Khooi, X. Z., Song, C. H., et al. (2023) · doi:10.1145/3630047.3630242 · Cited by 7 · see citing works
Securing Communication in the IoT-based Health Care Systems
Anggorojati, B., & Prasad, R. (2018) · Jurnal Ilmu Komputer dan Informasi · doi:10.21609/jiki.v11i1.562 · Cited by 7 · see citing works
“Afterwards, the device can request its identifier and corresponding private key securely using Authenticated Encryption with Associated Data (AEAD) [17].”
MethodAdvanced Techniques for Reconstruction of Incomplete Network Data
Matoušek, P., Pluskal, J., Ryšavý, O., et al. (2015) · Lecture notes of the Institute for Computer Sciences, Social Informatics and Telecommunications Engineering · doi:10.1007/978-3-319-25512-5_6 · Cited by 6 · see citing works
“The specification includes the cipher type (stream, block, AEAD [12]), the key size, the block size of the cipher (applied only to block ciphers), and the length of initialization vectors (or nonces).”
BackgroundNew security mechanisms for network time synchronization protocols
O’Donoghue, K., Sibold, D., & Fries, S. (2017) · IEEE International Symposium on Precision Clock Synchronization for Measurement, Control, and Communication · doi:10.1109/ispcs.2017.8056747 · Cited by 6 · see citing works
“It is calculated by applying the Authenticated Encryption with Associated Data approach [19].”
MethodPoettering, B., & Rösler, P. (2020) · IACR Transactions on Symmetric Cryptology · doi:10.46586/tosc.v2020.i1.121-143 · Cited by 6 · see citing works
A Study of KEM Generalizations
Poettering, B., & Rastikian, S. (2023) · Lecture notes in computer science · doi:10.1007/978-3-031-30731-7_3 · Cited by 5 · see citing works
“4 Note that the nonce processing is demanded by the AE/AEAD interface [18], while our KT application itself wouldn’t require it (and could fix the nonce to the all-zero string).”
MethodSRX–Secure Data Backup and Recovery for SGX Applications
Andrade, D., Silva, J. N., & Correia, M. P. (2022) · IEEE Access · doi:10.1109/access.2022.3162489 · Cited by 5 · see citing works
“AEAD [15] has functions Encrypt(K, N, P, A)→ C, T for authenticated encryption and Decrypt(K, N, C, A, T) → PorFAIL for authenticated decryption, where K is a secret key, N is a nonce, P is the data to be encrypted and authenticated, A is the data to be authenticated but not encrypted, C is the ciphertext which is of…”
BackgroundInfluentialBit‐Sliced Implementation of SM4 and New Performance Records
Miao, X., Li, L., Guo, C. F., Wang, M., & Wang, W. (2023) · IET Information Security · doi:10.1049/2023/1821499 · Cited by 5 · see citing works
A Mechanism for Seamless Cryptographic Rekeying in Real-Time Communication Systems
Bühler, H., Walz, A., & Sikora, A. (2021) · IEEE International Conference on Factory Communication Systems (WFCS) · doi:10.1109/wfcs46889.2021.9483613 · Cited by 4 · see citing works
“Authenticated encryption with associated data (AEAD) [5] provides both data confidentiality and authenticity.”
BackgroundExtended 3-Party $$\text{ACCE}$$ and Application to LoRaWAN 1.1
Canard, S., & Ferreira, L. (2019) · Lecture notes in computer science · doi:10.1007/978-3-030-23696-0_2 · Cited by 4 · see citing works
AES-GCM Authenticated Encryption in the Secure Real-time Transport Protocol (SRTP)
McGrew, D. A., & Igoe, K. (2015) · doi:10.17487/rfc7714 · Cited by 4 · see citing works
Self-citationCryptanalysis on End-to-End Encryption Schemes of Communication Tools and Its Research Trend
Isobe, T., Ito, R., & Minematsu, K. (2023) · Journal of Information Processing · doi:10.2197/ipsjjip.31.523 · Cited by 3 · see citing works
How Fast Can SM4 be in Software?
Miao, X., Guo, C. F., Wang, M., & Wang, W. (2023) · Lecture notes in computer science · doi:10.1007/978-3-031-26553-2_1 · Cited by 3 · see citing works
Session Traversal Utilities for NAT (STUN) Extension for Third-Party Authorization
Reddy, T. B., Patil, P., Ravindranath, R., et al. (2015) · doi:10.17487/rfc7635 · Cited by 3 · see citing works
McGrew, D. A., & Weis, B. (2010) · doi:10.17487/rfc6054 · Cited by 3 · see citing works
Self-citationHTTPA/2: A Trusted End-to-End Protocol for Web Services
King, G., & Wang, H. (2023) · Lecture notes in networks and systems · doi:10.1007/978-3-031-28073-3_55 · Cited by 2 · see citing works
JSON Web Algorithms (JWA) draft-ietf-jose-json-web-algorithms-14
Jones, M. B. (2014) · Cited by 2 · see citing works
A weakness in OCB3 used with short nonces allowing for a break of authenticity and confidentiality
Liénardy, J., & Lafitte, F. (2023) · Information Processing Letters · doi:10.1016/j.ipl.2023.106404 · Cited by 2 · see citing works
“As for the RFC 5116 [13], while it recommends to fix the nonce bytelength to 12, it does not include the OCB3 algorithm as an AEAD mode and the fixed nonce-length is not specified as a requirement (in fact, the variable nonce-length scenario is let as optional).”
BackgroundOn the Memory Fault Resilience of TLS 1.3
Brandstetter, L., Fischlin, M., Schröder, R. L., et al. (2020) · Lecture notes in computer science · doi:10.1007/978-3-030-64357-7_1 · Cited by 2 · see citing works
Trabalza, D. (2013) · KTH Publication Database DiVA (KTH Royal Institute of Technology) · Cited by 2 · see citing works
Trusted vs. Untrusted 5G Non-3GPP Access: A Comparative Study on Performance and Security
LUGLIO, M., Roseti, C., Verde, D., et al. (2025) · International Symposium on Networks, Computers and Communications (ISNCC) · doi:10.1109/isncc66965.2025.11250377 · Cited by 1 · see citing works
“AES could also be considered as a base crypto-algorithm for Authenticated Encryption with Associated Data (AEAD) [20], a family of modes of operation for block ciphers that provide both confidentiality and message authentication through a single operation.”
Cha, W., Lee, H. J., Kook, S., et al. (2025) · Sensors · doi:10.3390/s26010217 · Cited by 1 · see citing works
“We use hardware-rooted identity via physically unclonable functions (PUFs) [5], symmetric-first protection with AEAD [25] (e.g., AES-GCM [26], ChaCha20-Poly1305 [27]) [7,8,28–30], key derivation with HKDF [6,31], and cloud-assisted elliptic-curve operations for optional forward secrecy [3,4,22,32].”
Comparison of aead-algorithms for embedded systems іnternet of things
Совин, Я. Р., Khoma, V., & Отенко, В. І. (2019) · Komp'ûternì sistemi ta merežì · doi:10.23939/csn2019.01.076 · Cited by 1 · see citing works
TrustGlass: Human-Computer Trusted Paths with Augmented Reality Smart Glasses
Borges, H., Andrade, D., Silva, J. N., et al. (2023) · IEEE International Conference on Trust, Security and Privacy in Computing and Communications (TrustCom) · doi:10.1109/trustcom60117.2023.00106 · Cited by 1 · see citing works
“Functions: The AEAD scheme [24] provides the functions Encrypt ( K, N, P, A, IV ) → C, T and Decrypt ( K, N, C, IV ) → P or FAIL , where K is a secret key, N is a nonce, P is the plaintext to be encrypted, A is data included in the integrity check but not encrypted, IV is the initialization vector,…”
BackgroundLooking Further into the Security of End-to-End Encryption of SFrame
Shiraki, S., Kimura, H., & Isobe, T. (2024) · Journal of Information Processing · doi:10.2197/ipsjjip.32.679 · Cited by 1 · see citing works
ChaCha20 Cipher Cryptanalysis through SAT Problem Solving
Soboń, A., & Stachowiak, S. (2024) · IEEE International Scientific Conference on Informatics (Informatics) · doi:10.1109/informatics62280.2024.10900867 · Cited by 1 · see citing works
“1 block counter: (a 32-bit number starting at 0) [2][3].”
Jadin, M., & Tihon, G. (2017) · IEEE EUROCON - International Conference on Smart Technologies (EUROCON) · doi:10.1109/eurocon.2017.8011253 · Cited by 1 · see citing works
“These algorithms, according to [21], provide encryption and authentication of a plaintext and only authentication to some associated data.”
BackgroundSecuring Unprotected NTP Implementations Using an NTS Daemon
Langer, M., Behn, T., & Bermbach, R. (2019) · IEEE International Symposium on Precision Clock Synchronization for Measurement, Control, and Communication · doi:10.1109/ispcs.2019.8886645 · Cited by 1 · see citing works
“Using that link the symmetric keys for client and server (C2S, S2C) are exchanged and a suitable AEAD (Authenticated Encryption with Associated Data, [9]) method is negotiated, defining the encryption algorithm.”
Methodvan Oorschot, P. C. (2021) · Information security and cryptography · doi:10.1007/978-3-030-83411-1_2 · Cited by 1 · see citing works
On the design and implementation of secure network protocols
AlFardan, N. J. (2014) · Cited by 1 · see citing works
Pre-Shared Key Cipher Suites for TLS with
Badra, M. (2009)
Stabile usage of export regulatory standards in data security process
Plejic, B., Šilić, M., & Golub, M. (2018) · International Convention on Information and Communication Technology, Electronics and Microelectronics · doi:10.23919/mipro.2018.8400209
“By instead combining them, newer AEAD [6] algorithms achieve huge performance gains over their legacy counterparts.”
BackgroundQuicker: On the design and implementation of the QUIC protocol
Pittevils, K. (2018) · Document Server@UHasselt (UHasselt)
Analysis of the Level of Security Provided by Advanced Information and Communication Technologies
Budzko, V. I., Melnikov, D., Keyer, P. A., et al. (2019) · doi:10.1109/apsse47353.2019.00010
“Clear text protected by the AEAD protocol (Authenticated Encryption with Associated Data [14]) includes the message itself and variable-length padding data, which allows HIS to generate encrypted information blocks of arbitrary length, as well as send only fill data to hide the difference between periods of informatio…”
MethodIsobe, T., Ito, R., & Minematsu, K. (2025) · Journal of Information Security and Applications · doi:10.1016/j.jisa.2024.103958
Lightweight RISC-V Trusted Execution Environment with Hardware-based Encryption and Memory Isolation
Park, W., Kim, H., Ji, J., et al. (2022) · Journal of Digital Contents Society · doi:10.9728/dcs.2022.23.9.1813
Schwenk, J. (2022) · Information security and cryptography · doi:10.1007/978-3-031-19439-9_11
I Can’t Escape Myself: Cloud Inter-Processor Attestation and Sealing using Intel SGX
Andrade, D., Silva, J. N., & Correia, M. P. (2023) · IEEE Pacific Rim International Symposium on Dependable Computing (PRDC) · doi:10.1109/prdc59308.2023.00032
“This scheme provides confidentiality, integrity, and authenticity for encrypted plaintext, as well as integrity and authenticity for some associated data that is not encrypted [19].”
BackgroundArchitectures for performance and security in IoT smart grids
Kane, L. (2023) · Queensland University of Technology · doi:10.5204/thesis.eprints.245555
Building a Secure Cross-Device Communication Channel for Smart Devices Based on App Accounts
Pan, L., Qiu, R., Zhang, C., et al. (2024) · IEEE International Conference on Cyber Security and Resilience (CSR) · doi:10.1109/csr61664.2024.10679353
“AES-128-GCM, AES-256-GCM , and AES-256-CBC are symmetric ciphers [27] [28].”
BackgroundA Lightweight Hybrid Signcryption Scheme for Smart Devices
Pan, L., Qiu, R., & Yang, M. (2024) · International Conference on Security of Information and Networks (SIN) · doi:10.1109/sin63213.2024.10871686
Performance Evaluation of Quantum Secure User Plane Traffic in Beyond 5G Systems
Rajavelsamy, R., Aswin, S., Ganesha, S., et al. (2025) · National Conference on Communications · doi:10.1109/ncc63735.2025.10983296
Short Paper: Decentralized Fair Exchange for Assets across Blockchain and the Internet
Chen, L. F., Liu, Y., Lu, Y., et al. (2025) · doi:10.1109/cvc65719.2025.00018
Quantum-resistant authentication: Securing identity and data against quantum threats
González-Tablas, A. I., Universidad Carlos Ⅲ de Madrid, D. D. I., Vasco, M. I. G., & Universidad Carlos Ⅲ de Madrid, D. D. M. (2025) · AIMS Mathematics · doi:10.3934/math.2025779
“Some of the derived keys are used to encrypt and authenticate all exchanged data using an AE scheme with additional data ( AEAD ) [57].”
Contiguous Zero-Copy for Encrypted Transport Protocols
Rochet, F. (2025) · ACM SIGCOMM Computer Communication Review · doi:10.1145/3787927.3787929
“RFC5116 [37] is the proposed standard for interfacing AEADs with any software.”
InfluentialQuantifying Security Induced Overhead in Vision Based UAS Traffic Monitoring Pipelines
Anaroua, F. I., Watson, B., & Babiceanu, R. F. (2026) · Integrated Communications, Navigation and Surveillance Conference (ICNS) · doi:10.1109/icns69853.2026.11570438
“…[26] addressed secure intrusion detection for the Internet of UAS, demonstrating non-trivial processing costs for security integration in distributed monitoring, while [27] examined multi-device security for unmanned systems, highlighting authentication overhead in group communication frameworks.”
AES-iGCM : Enabling Fine-Grained TLS Inspection via Split Encryption–Authentication Keys
Tang, X., Chen, R., Xie, W., et al. (2026) · doi:10.1109/iicc69623.2026.11582448
“However, existing inspection schemes are all constrained by AEAD algorithms [7], making it difficult to achieve fine-grained access control.”
When We Talk Morse: Lightweight Parameter Encoding for Secure Federated Learning
Nguyen, H. M., Ghaffari, A., & Lovén, L. (2026) · Lecture notes in computer science · doi:10.1007/978-3-032-35576-8_24
- Authors
- McGrew, D.
- Corresponding author
- McGrew, D.
- ORCID
- McGrew, D.
- Publisher
- RFC Editor
- Published
- 2008-01
- OpenAlex
- W2268491029
- Semantic Scholar
- 603ebe1687384157d38ca6e1a8108041211bdf0a
- Cited by
- 104
- References
- 0
- Citations by year
- 2026: 6 · 2025: 7 · 2024: 5 · 2023: 14 · 2022: 6 · 2021: 6 · 2020: 5 · 2019: 9 · 2018: 8 · 2017: 10 · 2016: 2 · 2015: 8 · 2014: 4 · 2013: 2 · 2012: 3
- Type
- report
- Language
- en
- Open access
- closed
- Topics
- Physical Sciences › Computer Science › Artificial Intelligence › Cryptographic Implementations and Security
- Physical Sciences › Computer Science › Computer Networks and Communications › Advanced Authentication Protocols Security
- Physical Sciences › Computer Science › Information Systems › Cryptography and Residue Arithmetic
- Keywords
- authenticated encryption with associated data, cryptographic algorithms
About these checks
Registry, retraction, Cites and statistics results are computed, not judged, with one exception: a printed reference that no index lists is read once by a model before it counts as a citation error. Claims are extracted by a model and kept only when their quote appears verbatim in the text; each cited source is then checked, with a model’s help, for whether it says what the claim relies on. Those verdicts can be wrong — read the claim’s quote and the cited source before relying on one.
Statistics and arithmetic are recomputed, not judged.
Confidence bands are shown only for fields calibrated on our annotated test set. None is calibrated yet, so no band is shown.
What counts as a claim ›How we measure confidence ›How we check this ›
Are you an author, or do you see a problem with this page? Request a review